using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=>)(?=[a-z<])|(?<=[a-z>])(?=<)";
string substitution = @"\n";
string input = @"<abc>d<e><f>ghi<j>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}