const regex = new RegExp('(?<=>)(?=[a-z<])|(?<=[a-z>])(?=<)', 'g')
const str = `<abc>d<e><f>ghi<j>`;
const subst = `\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);