import Foundation
let pattern = #"(?<=>)(?=[a-z<])|(?<=[a-z>])(?=<)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"<abc>d<e><f>ghi<j>"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)