use strict;
my $str = '<abc>d<e><f>ghi<j>';
my $regex = qr/(?<=>)(?=[a-z<])|(?<=[a-z>])(?=<)/p;
my $subst = '\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";