#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^rgba?\((?:\s+)?(?<r>\d+(?<unit>%?))(?:\s+)?(?<separator>[\s|,])(?:\s+)?(?<g>\d+\k<unit>)(?:\s+)?\k<separator>(?:\s+)?(?<b>\d+\k<unit>)(?:\s+)?(?:(?<=(?:,.+))(?:,(?:\s+)?(?<a>(?:\d+)?(?:\.?\d+)))?(?:\s+)?)?\)$"
Local $sString = "// Valid" & @CRLF & _
"rgb(120 , 42 , 55)" & @CRLF & _
"rgb(23%, 100%, 0%)" & @CRLF & _
"rgb(120 42 55)" & @CRLF & _
"rgb(23% 100% 0%)" & @CRLF & _
"rgb(0 0 0)" & @CRLF & _
"rgba(23, 53, 0)" & @CRLF & _
"" & @CRLF & _
"// Invalid" & @CRLF & _
"rgb(255, 120 0)" & @CRLF & _
"rgb(100% 32 75)" & @CRLF & _
"" & @CRLF & _
"// When an alpha channel is defined, separator must be comma (not sure why but you can try it in browser to see for yourself)" & @CRLF & _
"" & @CRLF & _
"// Valid" & @CRLF & _
"rgb(255, 255, 255, 1)" & @CRLF & _
"rgb(255, 255, 255, .643)" & @CRLF & _
"rgb(255, 255, 255, 1.324 )" & @CRLF & _
"rgba(255, 255, 255, 1)" & @CRLF & _
"rgba(255, 255, 255, .643)" & @CRLF & _
"rgba(255, 255, 255, 1.324 )" & @CRLF & _
"" & @CRLF & _
"// Invalid" & @CRLF & _
"rgb(255, 255, 255, )" & @CRLF & _
"rgb(255, 255, 255, .)" & @CRLF & _
"rgba(255 255 255 1)" & @CRLF & _
"rgba(255 255 255, 1)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")