use strict;
my $str = '// Valid
rgb(120 , 42 , 55)
rgb(23%, 100%, 0%)
rgb(120 42 55)
rgb(23% 100% 0%)
rgb(0 0 0)
rgba(23, 53, 0)
// Invalid
rgb(255, 120 0)
rgb(100% 32 75)
// When an alpha channel is defined, separator must be comma (not sure why but you can try it in browser to see for yourself)
// Valid
rgb(255, 255, 255, 1)
rgb(255, 255, 255, .643)
rgb(255, 255, 255, 1.324 )
rgba(255, 255, 255, 1)
rgba(255, 255, 255, .643)
rgba(255, 255, 255, 1.324 )
// Invalid
rgb(255, 255, 255, )
rgb(255, 255, 255, .)
rgba(255 255 255 1)
rgba(255 255 255, 1)';
my $regex = qr/^rgba?\((?:\s+)?(?<r>\d+(?<unit>%?))(?:\s+)?(?<separator>[\s|,])(?:\s+)?(?<g>\d+\k<unit>)(?:\s+)?\k<separator>(?:\s+)?(?<b>\d+\k<unit>)(?:\s+)?(?:(?<=(?:,.+))(?:,(?:\s+)?(?<a>(?:\d+)?(?:\.?\d+)))?(?:\s+)?)?\)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}