import Foundation
let pattern = #"^rgba?\((?:\s+)?(?<r>\d+(?<unit>%?))(?:\s+)?(?<separator>[\s|,])(?:\s+)?(?<g>\d+\k<unit>)(?:\s+)?\k<separator>(?:\s+)?(?<b>\d+\k<unit>)(?:\s+)?(?:(?<=(?:,.+))(?:,(?:\s+)?(?<a>(?:\d+)?(?:\.?\d+)))?(?:\s+)?)?\)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
// Valid
rgb(120 , 42 , 55)
rgb(23%, 100%, 0%)
rgb(120 42 55)
rgb(23% 100% 0%)
rgb(0 0 0)
rgba(23, 53, 0)
// Invalid
rgb(255, 120 0)
rgb(100% 32 75)
// When an alpha channel is defined, separator must be comma (not sure why but you can try it in browser to see for yourself)
// Valid
rgb(255, 255, 255, 1)
rgb(255, 255, 255, .643)
rgb(255, 255, 255, 1.324 )
rgba(255, 255, 255, 1)
rgba(255, 255, 255, .643)
rgba(255, 255, 255, 1.324 )
// Invalid
rgb(255, 255, 255, )
rgb(255, 255, 255, .)
rgba(255 255 255 1)
rgba(255 255 255, 1)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)