import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^rgba?\\((?:\\s+)?(?<r>\\d+(?<unit>%?))(?:\\s+)?(?<separator>[\\s|,])(?:\\s+)?(?<g>\\d+\\k<unit>)(?:\\s+)?\\k<separator>(?:\\s+)?(?<b>\\d+\\k<unit>)(?:\\s+)?(?:(?<=(?:,.+))(?:,(?:\\s+)?(?<a>(?:\\d+)?(?:\\.?\\d+)))?(?:\\s+)?)?\\)$";
final String string = "// Valid\n"
+ "rgb(120 , 42 , 55)\n"
+ "rgb(23%, 100%, 0%)\n"
+ "rgb(120 42 55)\n"
+ "rgb(23% 100% 0%)\n"
+ "rgb(0 0 0)\n"
+ "rgba(23, 53, 0)\n\n"
+ "// Invalid\n"
+ "rgb(255, 120 0)\n"
+ "rgb(100% 32 75)\n\n"
+ "// When an alpha channel is defined, separator must be comma (not sure why but you can try it in browser to see for yourself)\n\n"
+ "// Valid\n"
+ "rgb(255, 255, 255, 1)\n"
+ "rgb(255, 255, 255, .643)\n"
+ "rgb(255, 255, 255, 1.324 )\n"
+ "rgba(255, 255, 255, 1)\n"
+ "rgba(255, 255, 255, .643)\n"
+ "rgba(255, 255, 255, 1.324 )\n\n"
+ "// Invalid\n"
+ "rgb(255, 255, 255, )\n"
+ "rgb(255, 255, 255, .)\n"
+ "rgba(255 255 255 1)\n"
+ "rgba(255 255 255, 1)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}