#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=[ \/]*[a-z0-9])[a-z0-9\/ ]{1,20}$"
Local $sString = "asdas//A9898AAA" & @CRLF & _
"abcde / asbas" & @CRLF & _
"avcdesc" & @CRLF & _
"AVASD/ASDB" & @CRLF & _
" ///aaa" & @CRLF & _
"aaaa / " & @CRLF & _
" //aa aa" & @CRLF & _
" /aaa aaa/// "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")