re = /^(?=[ \/]*[a-z0-9])[a-z0-9\/ ]{1,20}$/m
str = 'asdas//A9898AAA
abcde / asbas
avcdesc
AVASD/ASDB
///aaa
aaaa /
//aa aa
/aaa aaa/// '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end