$re = '/^(?=[ \/]*[a-z0-9])[a-z0-9\/ ]{1,20}$/m';
$str = 'asdas//A9898AAA
abcde / asbas
avcdesc
AVASD/ASDB
///aaa
aaaa /
//aa aa
/aaa aaa/// ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);