const regex = new RegExp('^(?=[ \\/]*[a-z0-9])[a-z0-9\\/ ]{1,20}$', 'gm')
const str = `asdas//A9898AAA
abcde / asbas
avcdesc
AVASD/ASDB
///aaa
aaaa /
//aa aa
/aaa aaa/// `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}