$re = '/^"\s*([^"]+?)\s*"\s*:\s*"?([^"]+)"?$/m';
$str = '"Name" : " hello"
"Name":[]--->Name=[] ( []--->[ ] )
"Name":123---->Name=123';
$subst = "\1= \"\2\"";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;