// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)^"\s*([^"]+?)\s*"\s*:\s*"?([^"]+)"?$"#).unwrap();
let string = "\"Name\" : \" hello\"
\"Name\":[]--->Name=[] ( []--->[ ] )
\"Name\":123---->Name=123";
let substitution = "\\1= \"\\2\"";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}