using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b((?![aeiou]{2}).)*[aeiou]\b";
string input = @"hielo hola agua hiellh aguas
hielo
hola
agua
hiellh
aguas";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}