re = /\b((?![aeiou]{2}).)*[aeiou]\b/m
str = 'hielo hola agua hiellh aguas
hielo
hola
agua
hiellh
aguas'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end