import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b((?![aeiou]{2}).)*[aeiou]\\b";
final String string = "hielo hola agua hiellh aguas\n"
+ "hielo\n"
+ "hola\n"
+ "agua\n"
+ "hiellh\n"
+ "aguas";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}