$re = '/\b((?![aeiou]{2}).)*[aeiou]\b/m';
$str = 'hielo hola agua hiellh aguas
hielo
hola
agua
hiellh
aguas';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);