#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[a-zA-Z0-9]+.*(?:\d+-\d+|\*)$"
Local $sString = "sensor1-2" & @CRLF & _
"s1-2" & @CRLF & _
"s*" & @CRLF & _
"s_s*" & @CRLF & _
"" & @CRLF & _
"sensor1" & @CRLF & _
"s1-" & @CRLF & _
"*s1-3"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")