$re = '/^[a-zA-Z0-9]+.*(?:\d+-\d+|\*)$/m';
$str = 'sensor1-2
s1-2
s*
s_s*
sensor1
s1-
*s1-3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);