package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[a-zA-Z0-9]+.*(?:\d+-\d+|\*)$`)
var str = `sensor1-2
s1-2
s*
s_s*
sensor1
s1-
*s1-3`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}