re = /^[a-zA-Z0-9]+.*(?:\d+-\d+|\*)$/m
str = 'sensor1-2
s1-2
s*
s_s*
sensor1
s1-
*s1-3'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end