using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\d)1[10]{16,}(?!\d)";
string input = @"------ Regla -------
12345678901234567890
----------------*---
11111111111111000
1111111111
10101010
11111111111111111
111111111111111111111
1010101010101010101010
10101010101010100
Otros nĂºmeros no en base 2:
123456789011121314151617181920
1234
12310000000000000000321
12310000000000000000";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}