import re
regex = re.compile(r"(?<!\d)1[10]{16,}(?!\d)", flags=re.MULTILINE)
test_str = ("------ Regla -------\n"
"12345678901234567890\n"
"----------------*---\n"
"11111111111111000\n"
"1111111111\n"
"10101010\n"
"11111111111111111\n"
"111111111111111111111\n"
"1010101010101010101010\n"
"10101010101010100\n\n"
"Otros nĂºmeros no en base 2:\n"
"123456789011121314151617181920\n"
"1234\n"
"12310000000000000000321\n"
"12310000000000000000")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")