$re = '/(?<!\d)1[10]{16,}(?!\d)/m';
$str = '------ Regla -------
12345678901234567890
----------------*---
11111111111111000
1111111111
10101010
11111111111111111
111111111111111111111
1010101010101010101010
10101010101010100
Otros números no en base 2:
123456789011121314151617181920
1234
12310000000000000000321
12310000000000000000';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);