package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?P<start>[^0-9.]+)(?P<digits>[0-9.]+)\s(?P<ending>[^0-9]+)`)
var str = `Станция Имя 05.2022 ФГУ8
Станция Имя Имядва 05.2022 (ФМП-4)
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}