use strict;
my $str = 'Станция Имя 05.2022 ФГУ8
Станция Имя Имядва 05.2022 (ФМП-4)
';
my $regex = qr/^(?P<start>[^0-9.]+)(?P<digits>[0-9.]+)\s(?P<ending>[^0-9]+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}