import re
regex = re.compile(r"^(?P<start>[^0-9.]+)(?P<digits>[0-9.]+)\s(?P<ending>[^0-9]+)", flags=re.MULTILINE)
test_str = ("Станция Имя 05.2022 ФГУ8\n"
"Станция Имя Имядва 05.2022 (ФМП-4)\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")