re = /^(?P<start>[^0-9.]+)(?P<digits>[0-9.]+)\s(?P<ending>[^0-9]+)/m
str = 'Станция Имя 05.2022 ФГУ8
Станция Имя Имядва 05.2022 (ФМП-4)
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end