import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?P<start>[^0-9.]+)(?P<digits>[0-9.]+)\\s(?P<ending>[^0-9]+)";
final String string = "Станция Имя 05.2022 ФГУ8\n"
+ "Станция Имя Имядва 05.2022 (ФМП-4)\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}