using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\s*>\s*)|\s+";
string substitution = @"\1";
string input = @"foo > bar > foo bar > foo > test > test this";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}