import re
regex = re.compile(r"(\s*>\s*)|\s+")
test_str = "foo > bar > foo bar > foo > test > test this"
subst = "\\1"
result = regex.sub(subst, test_str)
if result:
print(result)