$re = '/(\s*>\s*)|\s+/';
$str = 'foo > bar > foo bar > foo > test > test this';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;