re = /(\s*>\s*)|\s+/
str = 'foo > bar > foo bar > foo > test > test this'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result