use strict;
my $str = 'foo > bar > foo bar > foo > test > test this';
my $regex = qr/(\s*>\s*)|\s+/p;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";