#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(.*?)(?:\s+\S+){4}$"
Local $sString = "NAME WITH SPACES FIELD1 FIELD2 FIELD3 FIELD4" & @CRLF & _
"SECOND NAME WITH SPACES FIELD1 FIELD2 FIELD3 FIELD4" & @CRLF & _
"THIRD NAME WITH SPACES FIELD1 FIELD2 FIELD3 FIELD4" & @CRLF & _
"FOURTH NAME WITH SPACES FIELD1 FIELD2 FIELD3 FIELD4" & @CRLF & _
"FIFTH NAME WITH SOME MORE SPACES FIELD1 FIELD2 FIELD3 FIELD4"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")