package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(.*?)(?:\s+\S+){4}$`)
var str = `NAME WITH SPACES FIELD1 FIELD2 FIELD3 FIELD4
SECOND NAME WITH SPACES FIELD1 FIELD2 FIELD3 FIELD4
THIRD NAME WITH SPACES FIELD1 FIELD2 FIELD3 FIELD4
FOURTH NAME WITH SPACES FIELD1 FIELD2 FIELD3 FIELD4
FIFTH NAME WITH SOME MORE SPACES FIELD1 FIELD2 FIELD3 FIELD4`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}