const regex = /^(.*?)(?:\s+\S+){4}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(.*?)(?:\\s+\\S+){4}$', 'gm')
const str = `NAME WITH SPACES FIELD1 FIELD2 FIELD3 FIELD4
SECOND NAME WITH SPACES FIELD1 FIELD2 FIELD3 FIELD4
THIRD NAME WITH SPACES FIELD1 FIELD2 FIELD3 FIELD4
FOURTH NAME WITH SPACES FIELD1 FIELD2 FIELD3 FIELD4
FIFTH NAME WITH SOME MORE SPACES FIELD1 FIELD2 FIELD3 FIELD4`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}