$re = '/^(.*?)(?:\s+\S+){4}$/m';
$str = 'NAME WITH SPACES FIELD1 FIELD2 FIELD3 FIELD4
SECOND NAME WITH SPACES FIELD1 FIELD2 FIELD3 FIELD4
THIRD NAME WITH SPACES FIELD1 FIELD2 FIELD3 FIELD4
FOURTH NAME WITH SPACES FIELD1 FIELD2 FIELD3 FIELD4
FIFTH NAME WITH SOME MORE SPACES FIELD1 FIELD2 FIELD3 FIELD4';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);