import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(.*?)(?:\\s+\\S+){4}$";
final String string = "NAME WITH SPACES FIELD1 FIELD2 FIELD3 FIELD4\n"
+ "SECOND NAME WITH SPACES FIELD1 FIELD2 FIELD3 FIELD4\n"
+ "THIRD NAME WITH SPACES FIELD1 FIELD2 FIELD3 FIELD4\n"
+ "FOURTH NAME WITH SPACES FIELD1 FIELD2 FIELD3 FIELD4\n"
+ "FIFTH NAME WITH SOME MORE SPACES FIELD1 FIELD2 FIELD3 FIELD4";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}