#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?sx)(?sx)" & @CRLF & _
"\bblue\b(?=.*(bleu))" & @CRLF & _
"|" & @CRLF & _
"\bred\b(?=.*(rouge))"
Local $sString = "blue cheese, a red nose." & @CRLF & _
"bleu rouge"
Local $sSubst = "\1\2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)