import re
regex = re.compile(r"""
(?sx)
\bblue\b(?=.*(bleu))
|
\bred\b(?=.*(rouge))
""", flags=re.DOTALL | re.VERBOSE)
test_str = ("blue cheese, a red nose.\n"
"bleu rouge")
subst = "\\1\\2"
result = regex.sub(subst, test_str)
if result:
print(result)