package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?sx)(?sx)
\bblue\b(?=.*(bleu))
|
\bred\b(?=.*(rouge))`)
var str = `blue cheese, a red nose.
bleu rouge`
var substitution = "\1\2"
fmt.Println(re.ReplaceAllString(str, substitution))
}