import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?sx)\n"
+ "\\bblue\\b(?=.*(bleu))\n"
+ "|\n"
+ "\\bred\\b(?=.*(rouge))";
final String string = "blue cheese, a red nose.\n"
+ "bleu rouge";
final String subst = "\\1\\2";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}