# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b[uU](?=\b|(?![^\W\d_]))\.?\s*/utca /gm;t' <<< "Holics u 5/a\",
\"Holics U 5/a\",
\"Holics u5/a\",
\"Huolics u 5/a\",
\"Holics u. 5/a\",
\"Holuics u5\",
\"Holics and other stuff u more stuff after 5\",
\"Houlics utca 5"