#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\b[uU](?=\b|(?![^\W\d_]))\.?\s*"
Local $sString = "Holics u 5/a"," & @CRLF & _
" "Holics U 5/a"," & @CRLF & _
" "Holics u5/a"," & @CRLF & _
" "Huolics u 5/a"," & @CRLF & _
" "Holics u. 5/a"," & @CRLF & _
" "Holuics u5"," & @CRLF & _
" "Holics and other stuff u more stuff after 5"," & @CRLF & _
" "Houlics utca 5"
Local $sSubst = "utca "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)