$re = '/\b[uU](?=\b|(?![^\W\d_]))\.?\s*/m';
$str = 'Holics u 5/a",
"Holics U 5/a",
"Holics u5/a",
"Huolics u 5/a",
"Holics u. 5/a",
"Holuics u5",
"Holics and other stuff u more stuff after 5",
"Houlics utca 5';
$subst = "utca ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;