use strict;
my $str = 'Holics u 5/a",
"Holics U 5/a",
"Holics u5/a",
"Huolics u 5/a",
"Holics u. 5/a",
"Holuics u5",
"Holics and other stuff u more stuff after 5",
"Houlics utca 5';
my $regex = qr/\b[uU](?=\b|(?![^\W\d_]))\.?\s*/mp;
my $subst = 'utca ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";