package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<op>[A-Za-z0-9]*\<\/op>`)
var str = `<op>example2</op>
<op>asdas</op>
<simp>example1</simp><op>example2</op><val>example2</val>
<op></op>
<simp>example1</simp><op></op><val>example2</val>
<simp>example1</simp><op>12342</op><val>example2</val>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}