re = /<op>[A-Za-z0-9]*\<\/op>/m
str = '<op>example2</op>
<op>asdas</op>
<simp>example1</simp><op>example2</op><val>example2</val>
<op></op>
<simp>example1</simp><op></op><val>example2</val>
<simp>example1</simp><op>12342</op><val>example2</val>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end